En bref
- CVE-2024-22371 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant org.apache.camel:camel-core, camel (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.69%, plus élevée que 53.0% des vulnérabilités.
- Correctif : mettre à jour vers 3.21.4, 3.22.1, 4.0.4, 4.4.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.camel:camel-core Maven | ≥ 3.0.0, < 3.21.4≥ 3.22.0, < 3.22.1≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.4.0
| 3.21.43.22.14.0.44.4.0
|
| camel | = 3.22.0≥ 3.0.0, < 3.21.4≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.4.0
| 3.21.44.0.44.4.0
|
Description
Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel. This issue affects Apache Camel: from 3.0.0 through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0.
Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.
NVD description
Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0.
Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.
Autres vulnérabilités de org.apache.camel:camel-core
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free