En bref
- CVE-2024-23944 est une vulnérabilité MOYENNE (CVSS 5.3) touchant org.apache.zookeeper:zookeeper, zookeeper (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.25%, plus élevée que 16.0% des vulnérabilités.
- Correctif : mettre à jour vers 3.8.4, 3.9.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.zookeeper:zookeeper Maven | ≥ 3.6.0, ≤ 3.7.2≥ 3.8.0, < 3.8.4≥ 3.9.0, < 3.9.2
| 3.8.43.9.2
|
| zookeeper | ≥ 3.6.0, ≤ 3.7.2≥ 3.8.0, < 3.8.4≥ 3.9.0, < 3.9.2
| 3.8.43.9.2
|
Description
Information disclosure in persistent watchers handling in Apache ZooKeeper due to missing ACL check. It allows an attacker to monitor child znodes by attaching a persistent watcher (addWatch command) to a parent which the attacker has already access to. ZooKeeper server doesn't do ACL check when the persistent watcher is triggered and as a consequence, the full path of znodes that a watch event gets triggered upon is exposed to the owner of the watcher. It's important to note that only the path is exposed by this vulnerability, not the data of znode, but since znode path can contain sensitive information like user name or login ID, this issue is potentially critical.
Users are recommended to upgrade to version 3.9.2, 3.8.4 which fixes the issue.
NVD description
Information disclosure in persistent watchers handling in Apache ZooKeeper due to missing ACL check. It allows an attacker to monitor child znodes by attaching a persistent watcher (addWatch command) to a parent which the attacker has already access to. ZooKeeper server doesn't do ACL check when the persistent watcher is triggered and as a consequence, the full path of znodes that a watch event gets triggered upon is exposed to the owner of the watcher. It's important to note that only the path is exposed by this vulnerability, not the data of znode, but since znode path can contain sensitive information like user name or login ID, this issue is potentially critical.
Users are recommended to upgrade to version 3.9.2, 3.8.4 which fixes the issue.
Autres vulnérabilités de org.apache.zookeeper:zookeeper
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free