En bref
- CVE-2024-27097 est une vulnérabilité MOYENNE (CVSS 5.3) touchant ckan, ckan (okfn).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.44%, plus élevée que 38.2% des vulnérabilités.
- Correctif : mettre à jour vers 2.10.4, 2.9.11 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.10.0, < 2.10.4< 2.9.11
| 2.10.42.9.11
|
| ckan | ≥ 2.0, < 2.9.11≥ 2.10.0, < 2.10.4
| 2.9.112.10.4
|
Description
A user endpoint didn't perform filtering on an incoming parameter, which was added directly to the application log. This could lead to an attacker injecting false log entries or corrupt the log file format.
Patches
This has been fixed in the CKAN 2.9.11 and 2.10.4 versions
Workarounds
Override the /user/reset endpoint to filter the id parameter in order to exclude newlines
NVD description
A user endpoint didn't perform filtering on an incoming parameter, which was added directly to the application log. This could lead to an attacker injecting false log entries or corrupt the log file format. This has been fixed in the CKAN versions 2.9.11 and 2.10.4. Users are advised to upgrade. Users unable to upgrade should override the `/user/reset` endpoint to filter the `id` parameter in order to exclude newlines.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free