| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.pulsar:pulsar-functions-worker | ≥ 2.11.0, < 2.11.4≥ 2.4.0, < 2.10.6≥ 3.0.0, < 3.0.3≥ 3.1.0, < 3.1.3≥ 3.2.0, < 3.2.1 | 2.11.42.10.63.0.33.1.33.2.1 |
| pulsar | = 3.2.0≥ 2.11.0, < 2.11.4≥ 2.4.0, < 2.10.6≥ 3.0.0, < 3.0.3≥ 3.1.0, < 3.1.3 | 2.11.42.10.63.0.33.1.3 |
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true".
This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0.
2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free