En bref
- CVE-2024-27306 est une vulnérabilité MOYENNE (CVSS 6.1) touchant aiohttp, aiohttp (aiohttp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.67%, plus élevée que 51.8% des vulnérabilités.
- Correctif : mettre à jour vers 3.9.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| aiohttp PyPI | < 3.9.4
| 3.9.4
|
| aiohttp | < 3.9.4
| 3.9.4
|
Description
Summary
A XSS vulnerability exists on index pages for static file handling.
Details
When using web.static(..., show_index=True), the resulting index pages do not escape file names.
If users can upload files with arbitrary filenames to the static directory, the server is vulnerable to XSS attacks.
Workaround
We have always recommended using a reverse proxy server (e.g. nginx) for serving static files. Users following the recommendation are unaffected.
Other users can disable show_index if unable to upgrade.
Patch: https://github.com/aio-libs/aiohttp/pull/8319/files
NVD description
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. A XSS vulnerability exists on index pages for static file handling. This vulnerability is fixed in 3.9.4. We have always recommended using a reverse proxy server (e.g. nginx) for serving static files. Users following the recommendation are unaffected. Other users can disable `show_index` if unable to upgrade.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free