En bref
- CVE-2024-27315 est une vulnérabilité MOYENNE (CVSS 4.3) touchant apache-superset, superset (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.98%, plus élevée que 62.2% des vulnérabilités.
- Correctif : mettre à jour vers 3.1.1, 3.0.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-superset PyPI | ≥ 3.1.0, < 3.1.1< 3.0.4
| 3.1.13.0.4
|
| superset | ≥ 3.1.0, < 3.1.1< 3.0.4
| 3.1.13.0.4
|
Description
An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
NVD description
An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free