En bref
- CVE-2024-29733 est une vulnérabilité FAIBLE (CVSS 2.7) touchant apache-airflow-providers-ftp, apache-airflow-providers-ftp (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.63%, plus élevée que 50.4% des vulnérabilités.
- Correctif : mettre à jour vers 3.7.0 ou plus récent.
Description
Improper Certificate Validation vulnerability in Apache Airflow FTP Provider.
The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly.
This issue affects Apache Airflow FTP Provider: before 3.7.0.
Users are recommended to upgrade to version 3.7.0, which fixes the issue.
NVD description
Improper Certificate Validation vulnerability in Apache Airflow FTP Provider.
The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly.
This issue affects Apache Airflow FTP Provider: before 3.7.0.
Users are recommended to upgrade to version 3.7.0, which fixes the issue.
Autres vulnérabilités de apache-airflow-providers-ftp
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free