En bref
- CVE-2024-29904 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant codeigniter4/framework, codeigniter (codeigniter).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.77%, plus élevée que 55.7% des vulnérabilités.
- Correctif : mettre à jour vers 4.4.7 ou plus récent.
Description
Impact
A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server.
Patches
Upgrade to v4.4.7 or later. See upgrading guide.
Workarounds
- Disabling Auto Routing prevents a known attack vector in the framework.
- Do not pass invalid values to the
lang() function or Language class.
References
NVD description
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.
Autres vulnérabilités de codeigniter4/framework
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free