En bref
- CVE-2024-31864 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant org.apache.zeppelin:zeppelin-jdbc, zeppelin (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 69.6% des vulnérabilités.
- Correctif : mettre à jour vers 0.11.1 ou plus récent.
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin.
The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
NVD description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin.
The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver.
This issue affects Apache Zeppelin: before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Autres vulnérabilités de org.apache.zeppelin:zeppelin-jdbc
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free