En bref
- CVE-2024-35199 est une vulnérabilité ÉLEVÉE (CVSS 8.2) touchant torchserve, torchserve (pytorch).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.64%, plus élevée que 50.5% des vulnérabilités.
- Correctif : mettre à jour vers 0.11.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| torchserve PyPI | ≥ 0.3.0, < 0.11.0
| 0.11.0
|
| torchserve | ≥ 0.3.0, < 0.11.0
| 0.11.0
|
Description
Impact
The two gRPC ports 7070 and 7071, are not bound to localhost by default, so when TorchServe is launched, these two interfaces are bound to all interfaces. Customers using PyTorch inference Deep Learning Containers (DLC) through Amazon SageMaker and EKS are not affected.
Patches
This issue in TorchServe has been fixed in #3083.
TorchServe release 0.11.0 includes the fix to address this vulnerability.
References
Thank Kroll Cyber Risk for for responsibly disclosing this issue.
If you have any questions or comments about this advisory, we ask that you contact AWS Security via our vulnerability reporting page or directly via email to [email protected]. Please do not create a public GitHub issue.
NVD description
TorchServe is a flexible and easy-to-use tool for serving and scaling PyTorch models in production. In affected versions the two gRPC ports 7070 and 7071, are not bound to [localhost](http://localhost/) by default, so when TorchServe is launched, these two interfaces are bound to all interfaces. Customers using PyTorch inference Deep Learning Containers (DLC) through Amazon SageMaker and EKS are not affected. This issue in TorchServe has been fixed in PR #3083. TorchServe release 0.11.0 includes the fix to address this vulnerability. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free