En bref
- CVE-2024-39877 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant apache-airflow, airflow (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.7%, plus élevée que 77.6% des vulnérabilités.
- Correctif : mettre à jour vers 2.9.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.4.0, < 2.9.3
| 2.9.3
|
| airflow | ≥ 2.4.0, < 2.9.3
| 2.9.3
|
Description
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
NVD description
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free