| Package | Affected versions | Patched versions |
|---|---|---|
| llama-index | ≥ 0.9.47, < 0.10.13< 0.10.13 | 0.10.13 |
| llama-index-llms-rungpt | < 0.1.3 | 0.1.3 |
| llamaindex | ≥ 0.9.47, < 0.10.13 | 0.10.13 |
A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free