En bref
- CVE-2024-41962 est une vulnérabilité MOYENNE (CVSS 6.3) touchant bostr (yonle), bostr.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.30%, plus élevée que 22.6% des vulnérabilités.
- Correctif : mettre à jour vers 3.0.10 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| bostr | < 3.0.10
| 3.0.10
|
| bostr npm | < 3.0.10
| 3.0.10
|
Description
Even with authorized_keys is filled with allowed pubkeys, If noscraper is enabled, It will allow anyone to use bouncer even it's pubkey is not in authorized_keys.
Impact
Patches
Available on version 3.0.10
Workarounds
Disable noscraper if you have authorized_keys being set in config
References
This line of code is the cause.
NVD description
Bostr is an nostr relay aggregator proxy that acts like a regular nostr relay. bostr let everyone in even having authorized_keys being set when noscraper is set to true. This vulnerability is fixed in 3.0.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free