En bref
- CVE-2024-43800 est une vulnérabilité MOYENNE (CVSS 4.7) touchant serve-static (openjsf), serve-static.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.63%, plus élevée que 50.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.0, 1.16.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| serve-static | ≥ 2.0.0, < 2.1.0< 1.16.0
| 2.1.01.16.0
|
| serve-static npm | ≥ 2.0.0, < 2.1.0< 1.16.0
| 2.1.01.16.0
|
Description
Impact
passing untrusted user input - even after sanitizing it - to redirect() may execute untrusted code
Patches
this issue is patched in serve-static 1.16.0
Workarounds
users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist
Details
successful exploitation of this vector requires the following:
- The attacker MUST control the input to response.redirect()
- express MUST NOT redirect before the template appears
- the browser MUST NOT complete redirection before:
- the user MUST click on the link in the template
NVD description
serve-static serves static files. serve-static passes untrusted user input - even after sanitizing it - to redirect() may execute untrusted code. This issue is patched in serve-static 1.16.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free