En bref
- CVE-2024-45216 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant org.apache.solr:solr, solr (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 92.7%, plus élevée que 99.8% des vulnérabilités.
- Correctif : mettre à jour vers 8.11.4, 9.7.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.solr:solr Maven | ≥ 5.3.0, < 8.11.4≥ 9.0.0, < 9.7.0
| 8.11.49.7.0
|
| solr | ≥ 5.3.0, < 8.11.4≥ 9.0.0, < 9.7.0
| 8.11.49.7.0
|
Description
Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing.
This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0.
Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.
NVD description
Improper Authentication vulnerability in Apache Solr.
Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass.
A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path.
This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing.
This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0.
Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.
Autres vulnérabilités de org.apache.solr:solr
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free