En bref
- CVE-2024-45401 est une vulnérabilité ÉLEVÉE (CVSS 7.1) touchant github.com/stripe/stripe-cli, stripe cli (stripe).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.21%, plus élevée que 10.9% des vulnérabilités.
- Correctif : mettre à jour vers 1.21.3 ou plus récent.
Description
Impact
A vulnerability exists in stripe-cli versions 1.11.1 and higher where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files.
The update addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path.
There has been no evidence of exploitation of this vulnerability.
Recommendation
Upgrade to stripe-cli v1.21.3.
Acknowledgements
Thank you to 0xacb and bordiez for reporting this vulnerability.
For more information
Email us at [email protected]
NVD description
stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.
Autres vulnérabilités de github.com/stripe/stripe-cli
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free