En bref
- CVE-2024-45590 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant body-parser (openjsf), body-parser.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.82%, plus élevée que 57.4% des vulnérabilités.
- Correctif : mettre à jour vers 1.20.3 ou plus récent.
Description
Impact
body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service.
Patches
this issue is patched in 1.20.3
References
NVD description
body-parser is Node.js body parsing middleware. body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service. This issue is patched in 1.20.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free