En bref
- CVE-2024-47178 est une vulnérabilité MOYENNE (CVSS 5.3) touchant basic-auth-connect (expressjs), basic-auth-connect.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.52%, plus élevée que 44.4% des vulnérabilités.
- Correctif : mettre à jour vers 1.1.0 ou plus récent.
Description
Impact
basic-auth-connect <1.1.0 uses a timing-unsafe equality comparison that can leak timing information
Patches
this issue has been fixed in basic-auth-connect 1.1.0
References
NVD description
basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free