En bref
- CVE-2024-48911 est une vulnérabilité ÉLEVÉE (CVSS 7.8) touchant opencanary, opencanary (thinkst).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.22%, plus élevée que 12.9% des vulnérabilités.
- Correctif : mettre à jour vers 0.9.4, 0.9.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| opencanary PyPI | < 0.9.4< 0.9.5
| 0.9.40.9.5
|
| opencanary | < 0.9.4
| 0.9.4
|
Description
Impact
OpenCanary directly executed commands taken from its config file. Where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon.
Thanks to the folks at Whirlylabs for finding and fixing this.
Patches
Upgrade to 0.9.4 or higher.
NVD description
OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon. Version 0.9.4 contains a fix for the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free