En bref
- CVE-2024-48944 est une vulnérabilité MOYENNE (CVSS 6.5) touchant org.apache.kylin:kylin-common-server, kylin (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.64%, plus élevée que 50.8% des vulnérabilités.
- Correctif : mettre à jour vers 5.0.2 ou plus récent.
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api endpoint open for service.
This issue affects Apache Kylin: from 5.0.0 through 5.0.1.
Users are recommended to upgrade to version 5.0.2, which fixes the issue.
NVD description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api
endpoint open for service.
This issue affects Apache Kylin: from 5.0.0
through
5.0.1.
Users are recommended to upgrade to version 5.0.2, which fixes the issue.
Autres vulnérabilités de org.apache.kylin:kylin-common-server
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free