En bref
- CVE-2024-49376 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant Autolab, autolab (autolabproject).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.47%, plus élevée que 40.5% des vulnérabilités.
- Correctif : mettre à jour vers 3.0.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| Autolab RubyGems | ≥ 3.0.0, < 3.0.1
| 3.0.1
|
| autolab | = 3.0.0
| No fix yet |
Description
Impact
For email-based accounts, users with insufficient privileges could reset and theoretically access privileged users' accounts by resetting their passwords.
Patches
This is fixed in v3.0.1.
Workarounds
No workarounds.
For more information
If you have any questions or comments about this advisory:
Open an issue in https://github.com/autolab/Autolab/
Email us at [email protected]
NVD description
Autolab, a course management service that enables auto-graded programming assignments, has misconfigured reset password permissions in version 3.0.0. For email-based accounts, users with insufficient privileges could reset and theoretically access privileged users' accounts by resetting their passwords. This issue is fixed in version 3.0.1. No known workarounds exist.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free