En bref
- CVE-2024-51996 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant symfony/security-http.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.62%, plus élevée que 49.7% des vulnérabilités.
- Correctif : mettre à jour vers 5.4.47, 6.4.15, 7.1.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| symfony/security-http Packagist | ≥ 5.3.0, < 5.4.47≥ 6.0.0-BETA1, < 6.4.15≥ 7.0.0-BETA1, < 7.1.8
| 5.4.476.4.157.1.8
|
Description
Description
When consuming a persisted remember-me cookie, Symfony does not check if the username persisted in the database matches the username attached with the cookie, leading to authentication bypass.
Resolution
The PersistentRememberMeHandler class now ensures the submitted username is the cookie owner.
The patch for this issue is available here for branch 5.4.
Credits
We would like to thank Moritz Rauch - Pentryx AG for reporting the issue and Jérémy Derussé for providing the fix.
NVD description
Symphony process is a module for the Symphony PHP framework which executes commands in sub-processes. When consuming a persisted remember-me cookie, Symfony does not check if the username persisted in the database matches the username attached with the cookie, leading to authentication bypass. This vulnerability is fixed in 5.4.47, 6.4.15, and 7.1.8.
Autres vulnérabilités de symfony/security-http
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free