En bref
- CVE-2024-53677 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant org.apache.struts:struts2-core, struts (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 72.4%, plus élevée que 99.4% des vulnérabilités.
- Correctif : mettre à jour vers 6.4.0 ou plus récent.
Description
File upload logic is flawed vulnerability in Apache Struts. An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution.
This issue affects Apache Struts: from 2.0.0 before 6.4.0.
Users are recommended to upgrade to version 6.4.0 at least and migrate to the new file upload mechanism https://struts.apache.org/core-developers/file-upload. If you are not using an old file upload logic based on FileuploadInterceptor your application is safe.
You can find more details in https://cwiki.apache.org/confluence/display/WW/S2-067 .
NVD description
File upload logic in Apache Struts is flawed. An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution.
This issue affects Apache Struts: from 2.0.0 before 6.4.0.
Users are recommended to upgrade to version 6.4.0 at least and migrate to the new file upload mechanism https://struts.apache.org/core-developers/file-upload . If you are not using an old file upload logic based on FileuploadInterceptor your application is safe.
You can find more details in https://cwiki.apache.org/confluence/display/WW/S2-067
Autres vulnérabilités de org.apache.struts:struts2-core
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free