En bref
- CVE-2025-15379 est une vulnérabilité CRITIQUE (CVSS 10.0) touchant mlflow, mlflow (lfprojects).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.4%, plus élevée que 84.0% des vulnérabilités.
- Correctif : mettre à jour vers 3.8.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.8.1
| 3.8.1
|
| mlflow | ≥ 3.8.0, < 3.8.1
| 3.8.1
|
Description
A command injection vulnerability exists in MLflow's model serving container initialization code, specifically in the _install_model_dependencies_to_env() function. When deploying a model with env_manager=LOCAL, MLflow reads dependency specifications from the model artifact's python_env.yaml file and directly interpolates them into a shell command without sanitization. This allows an attacker to supply a malicious model artifact and achieve arbitrary command execution on systems that deploy the model. The vulnerability affects versions 3.8.0 and is fixed in version 3.8.1.
NVD description
A command injection vulnerability exists in MLflow's model serving container initialization code, specifically in the `_install_model_dependencies_to_env()` function. When deploying a model with `env_manager=LOCAL`, MLflow reads dependency specifications from the model artifact's `python_env.yaml` file and directly interpolates them into a shell command without sanitization. This allows an attacker to supply a malicious model artifact and achieve arbitrary command execution on systems that deploy the model. The vulnerability affects versions 3.8.0 and is fixed in version 3.8.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free