En bref
- CVE-2025-2000 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant qiskit, qiskit-terra, qiskit (ibm).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.81%, plus élevée que 57.1% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.0rc2, 1.4.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| qiskit PyPI | ≥ 2.0.0rc1, < 2.0.0rc2< 1.4.2
| 2.0.0rc21.4.2
|
| qiskit-terra PyPI | ≥ 0.18.0, ≤ 0.46.3
| No fix yet |
| qiskit | ≥ 0.18.0, < 1.4.2
| 1.4.2
|
Description
Impact
A maliciously crafted QPY file can potentially execute arbitrary-code embedded in the payload without privilege escalation when deserializing QPY formats < 13. A python process calling Qiskit's qiskit.qpy.load() function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of a specially constructed payload.
Patches
Fixed in Qiskit 1.4.2 and in Qiskit 2.0.0rc2
NVD description
A maliciously crafted QPY file can potential execute arbitrary-code embedded in the payload without privilege escalation when deserialising QPY formats < 13. A python process calling Qiskit 0.18.0 through 1.4.1's `qiskit.qpy.load()` function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of specially constructed payload.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free