En bref
- CVE-2025-27018 est une vulnérabilité MOYENNE (CVSS 6.3) touchant apache-airflow-providers-mysql, apache-airflow-providers-mysql (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.91%, plus élevée que 60.0% des vulnérabilités.
- Correctif : mettre à jour vers 6.2.0 ou plus récent.
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.
When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended.
It could lead to data corruption, modification and others.
This issue affects Apache Airflow MySQL Provider: before 6.2.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
NVD description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.
When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended.
It could lead to data corruption, modification and others.
This issue affects Apache Airflow MySQL Provider: before 6.2.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
Autres vulnérabilités de apache-airflow-providers-mysql
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free