En bref
- CVE-2025-32427 est une vulnérabilité MOYENNE (CVSS 5.4) touchant verbb/formie, formie (verbb).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.23%, plus élevée que 14.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.44 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| verbb/formie Packagist | < 2.1.44
| 2.1.44
|
| formie | < 2.1.44
| 2.1.44
|
Description
Impact
When importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported.
As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export.
Patches
This has been fixed in Formie 2.1.44. Users should ensure they are running at least this version.
NVD description
Formie is a Craft CMS plugin for creating forms. Prior to 2.1.44, when importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported. As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export. This vulnerability is fixed in 2.1.44.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free