En bref
- CVE-2025-46343 est une vulnérabilité MOYENNE (CVSS 5.4) touchant n8n (n8n), n8n.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.27%, plus élevée que 19.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.90.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| n8n | < 1.90.0
| 1.90.0
|
| n8n npm | < 1.90.0
| 1.90.0
|
Description
Impact
n8n workflows can store and serve binary files, which are accessible to authenticated users. However, there was no restriction on the MIME type of uploaded files, and the MIME type could be controlled via a GET parameter. This allowed the server to respond with any MIME type, potentially enabling malicious content to be interpreted and executed by the browser.
An authenticated attacker with member-level permissions could exploit this by uploading a crafted HTML file containing malicious JavaScript. When another user visits the binary data endpoint with the MIME type set to text/html, the script executes in the context of the user’s session. This script could, for example, send a request to change the user’s email address in their account settings, effectively enabling account takeover.
Patches
Credit
We would like to thank @Mahmoud0x00 for reporting this issue.
NVD description
n8n is a workflow automation platform. Prior to version 1.90.0, n8n is vulnerable to stored cross-site scripting (XSS) through the attachments view endpoint. n8n workflows can store and serve binary files, which are accessible to authenticated users. However, there is no restriction on the MIME type of uploaded files, and the MIME type could be controlled via a GET parameter. This allows the server to respond with any MIME type, potentially enabling malicious content to be interpreted and executed by the browser. An authenticated attacker with member-level permissions could exploit this by uploading a crafted HTML file containing malicious JavaScript. When another user visits the binary data endpoint with the MIME type set to text/html, the script executes in the context of the user’s session. This script could send a request to change the user’s email address in their account settings, effectively enabling account takeover. This issue has been patched in version 1.90.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free