En bref
- CVE-2025-46812 est une vulnérabilité FAIBLE (CVSS 2.0) touchant trix.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.72%, plus élevée que 53.8% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.15 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| trix npm | < 2.1.15
| 2.1.15
|
Description
Impact
The Trix editor, in versions prior to 2.1.15, is vulnerable to XSS attacks when pasting malicious code.
An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed.
Patches
Update Recommendation: Users should upgrade to Trix editor version 2.1.15 or later.
References
The XSS vulnerability was reported by HackerOne researcher hiumee.
NVD description
Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.15 are vulnerable to XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. This issue has been patched in version 2.1.15.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free