En bref
- CVE-2025-49596 est une vulnérabilité CRITIQUE (CVSS 9.4) touchant @modelcontextprotocol/inspector.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 44.5%, plus élevée que 98.8% des vulnérabilités.
- Correctif : mettre à jour vers 0.14.1 ou plus récent.
Description
Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Credit: Rémy Marot [email protected]
NVD description
The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Autres vulnérabilités de @modelcontextprotocol/inspector
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free