En bref
- CVE-2025-50213 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant apache-airflow-providers-snowflake, apache-airflow-providers-snowflake (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.77%, plus élevée que 55.8% des vulnérabilités.
- Correctif : mettre à jour vers 6.4.0 ou plus récent.
Description
Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.
This issue affects Apache Airflow Providers Snowflake: before 6.4.0.
Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection
Users are recommended to upgrade to version 6.4.0, which fixes the issue.
NVD description
Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.
This issue affects Apache Airflow Providers Snowflake: before 6.4.0.
Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection
Users are recommended to upgrade to version 6.4.0, which fixes the issue.
Autres vulnérabilités de apache-airflow-providers-snowflake
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free