En bref
- CVE-2025-54998 est une vulnérabilité MOYENNE (CVSS 5.3) touchant github.com/openbao/openbao, openbao (openbao).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.23%, plus élevée que 14.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.3.2, 0.0.0-20250807212521-c52795c1ef74 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/openbao/openbao Go | ≥ 0.1.0, < 2.3.2≥ 0.1.0< 0.0.0-20250807212521-c52795c1ef74
| 2.3.20.0.0-20250807212521-c52795c1ef74
|
| openbao | < 2.3.2
| 2.3.2
|
Description
Impact
Attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions.
Patches
OpenBao v2.3.2 will patch this issue.
Workarounds
Existing users may apply rate-limiting quotas on the authentication endpoints: https://openbao.org/api-docs/system/rate-limit-quotas/
References
This issue was disclosed to HashiCorp and is the OpenBao equivalent of the following tickets:
NVD description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 0.1.0 through 2.3.1, attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions. This is fixed in version 2.3.2. To work around this issue, existing users may apply rate-limiting quotas on the authentication endpoints:, see https://openbao.org/api-docs/system/rate-limit-quotas/.
Autres vulnérabilités de github.com/openbao/openbao
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free