En bref
- CVE-2025-55193 est une vulnérabilité FAIBLE (CVSS 2.7) touchant activerecord.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.59%, plus élevée que 48.4% des vulnérabilités.
- Correctif : mettre à jour vers 7.2.2.2, 8.0.2.1, 7.1.5.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| activerecord RubyGems | ≥ 7.2, < 7.2.2.2≥ 8.0, < 8.0.2.1< 7.1.5.2
| 7.2.2.28.0.2.17.1.5.2
|
Description
This vulnerability has been assigned the CVE identifier CVE-2025-55193
Impact
The ID passed to find or similar methods may be logged without escaping. If this is directly to the terminal it may include unescaped ANSI sequences.
Releases
The fixed releases are available at the normal locations.
Credits
Thanks to lio346 from Unit 515 of OPSWAT for reporting this vulnerability
NVD description
Active Record connects classes to relational database tables. Prior to versions 7.1.5.2, 7.2.2.2, and 8.0.2.1, the ID passed to find or similar methods may be logged without escaping. If this is directly to the terminal it may include unescaped ANSI sequences. This issue has been patched in versions 7.1.5.2, 7.2.2.2, and 8.0.2.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free