En bref
- CVE-2025-57809 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant xgrammar, xgrammar (mlc-ai).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.48%, plus élevée que 41.9% des vulnérabilités.
- Correctif : mettre à jour vers 0.1.21 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| xgrammar PyPI | < 0.1.21
| 0.1.21
|
| xgrammar | < 0.1.21
| 0.1.21
|
Description
Summary
This issue: http://github.com/mlc-ai/xgrammar/issues/250 should have it's own security advisory. Since several tools accept and pass user supplied grammars to xgrammar, and it is so easy to trigger it seems like a High.
NVD description
XGrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.21, XGrammar has an infinite recursion issue in the grammar. This issue has been resolved in version 0.1.21.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free