En bref
- CVE-2025-6167 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant python-a2a, python a2a (themanojdesai).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.77%, plus élevée que 55.5% des vulnérabilités.
- Correctif : mettre à jour vers 0.5.6 ou plus récent.
Description
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
NVD description
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free