En bref
- CVE-2025-61924 est une vulnérabilité FAIBLE (CVSS 3.8) touchant prestashop/ps_checkout, prestashop checkout (prestashop).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.27%, plus élevée que 19.2% des vulnérabilités.
- Correctif : mettre à jour vers 5.0.5, 4.4.1, 7.5.0.5, 8.4.4.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| prestashop/ps_checkout Packagist | ≥ 5.0.0, < 5.0.5< 4.4.1
| 5.0.54.4.1
|
| prestashop checkout | ≥ 7.5.0.1, < 7.5.0.5≥ 8.3.1.0, < 8.4.4.1≥ 8.5.0.0, < 8.5.0.5≥ 9.4.3.1, < 9.5.0.5< 7.4.4.1
| 7.5.0.58.4.4.18.5.0.59.5.0.57.4.4.1
|
Description
Impact
Wrong usage of the PHP array_search() allows bypass of validation.
Patches
The problem has been patched in versions:
- v4.4.1 for PrestaShop 1.7 (build number: 7.4.4.1)
- v4.4.1 for PrestaShop 8 (build number: 8.4.4.1)
- v5.0.5 for PrestaShop 1.7 (build number: 7.5.0.5)
- v5.0.5 for PrestaShop 8 (build number: 8.5.0.5)
- v5.0.5 for PrestaShop 9 (build number: 9.5.0.5)
Read the Versioning policy to learn more about the build number.
Credits
Léo CUNÉAZ reported this issue.
NVD description
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Autres vulnérabilités de prestashop/ps_checkout
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free