En bref
- CVE-2025-62374 est une vulnérabilité MOYENNE (CVSS 6.4) touchant parse.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.41%, plus élevée que 35.3% des vulnérabilités.
- Correctif : mettre à jour vers 7.0.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse npm | < 7.0.0
| 7.0.0
|
Description
Summary
Prototype pollution capabilities on various APIs.
Details
Injection of malicious payload allows attacker to remotely execute arbitrary code. Parse.Object and internal APIs are affected, specifically:
ParseObject.fromJSON
ParseObject.pin
ParseObject.registerSubclass
ObjectStateMutations (internal)
encode/decode (internal)
PoC
Demonstrative tests added as part of the fix.
References
NVD description
Parse Javascript SDK provides access to the powerful Parse Server backend from your JavaScript app. Prior to 7.0.0, injection of malicious payload allows attacker to remotely execute arbitrary code. ParseObject.fromJSON, ParseObject.pin, ParseObject.registerSubclass, ObjectStateMutations (internal), and encode/decode (internal) are affected. This vulnerability is fixed in 7.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free