En bref
- CVE-2025-62708 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.44%, plus élevée que 38.6% des vulnérabilités.
- Correctif : mettre à jour vers 6.1.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.1.3
| 6.1.3
|
| pypdf | < 6.1.3
| 6.1.3
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter.
Patches
This has been fixed in pypdf==6.1.3.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3502.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter. This has been fixed in pypdf version 6.1.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free