En bref
- CVE-2025-64168 est une vulnérabilité ÉLEVÉE (CVSS 7.1) touchant agno.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.16%, plus élevée que 5.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.2.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| agno PyPI | ≥ 2.0.0, < 2.2.2
| 2.2.2
|
Description
Impact
Under certain conditions (under high concurrency), when session_state is passed to an Agent or Team during run or arun calls, a race condition can occur, causing a session_state to be assigned and persisted to the incorrect session. This may result in user data from one session being exposed to another user.
Patches
This has been patched in version 2.2.2. Upgrade with pip install -U agno.
NVD description
Agno is a multi-agent framework, runtime and control plane. From 2.0.0 to before 2.2.2, under high concurrency, when session_state is passed to Agent or Team during run or arun calls, a race condition can occur, causing a session_state to be assigned and persisted to the incorrect session. This may result in user data from one session being exposed to another user. This has been patched in version 2.2.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free