En bref
- CVE-2025-64509 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant bugsink.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.34%, plus élevée que 27.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| bugsink PyPI | < 2.0.6
| 2.0.6
|
Description
Impact
In affected versions, a specially crafted Brotli-compressed envelope can cause Bugsink to spend excessive CPU time in decompression, leading to denial of service.
This can be done if the DSN is known, which it is in many common setups (JavaScript, Mobile Apps).
Patches
Patched in Bugsink 2.0.6
References
The vulnerability in this security advisory is similar to, but distinct from, another brotli-related problem in Bugsink:
https://github.com/bugsink/bugsink/security/advisories/GHSA-fc2v-vcwj-269v
NVD description
Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.6, a specially crafted Brotli-compressed envelope can cause Bugsink to spend excessive CPU time in decompression, leading to denial of service. This can be done if the DSN is known, which it is in many common setups (JavaScript, Mobile Apps). The issue is patched in Bugsink 2.0.6. The vulnerability is similar to, but distinct from, another brotli-related problem in Bugsink, GHSA-fc2v-vcwj-269v/CVE-2025-64508.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free