En bref
- CVE-2025-65995 est une vulnérabilité MOYENNE (CVSS 6.5) touchant apache-airflow, airflow (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.89%, plus élevée que 59.3% des vulnérabilités.
- Correctif : mettre à jour vers 3.1.5rc1, 2.11.1, 3.1.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0b1, < 3.1.5rc1< 2.11.1
| 3.1.5rc12.11.1
|
| airflow | ≥ 3.0.0, < 3.1.4< 2.11.1
| 3.1.42.11.1
|
Description
When a DAG failed during parsing, Airflow’s error-reporting in the UI could include the full kwargs passed to the operators. If those kwargs contained sensitive values (such as secrets), they might be exposed in the UI tracebacks to authenticated users who had permission to view that DAG.
The issue has been fixed in Airflow 3.1.5rc1 and 2.11.1, and users are strongly advised to upgrade to prevent potential disclosure of sensitive information.
NVD description
When a DAG failed during parsing, Airflow’s error-reporting in the UI could include the full kwargs passed to the operators. If those kwargs contained sensitive values (such as secrets), they might be exposed in the UI tracebacks to authenticated users who had permission to view that DAG.
The issue has been fixed in Airflow 3.1.4 and 2.11.1, and users are strongly advised to upgrade to prevent potential disclosure of sensitive information.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free