En bref
- CVE-2025-67505 est une vulnérabilité ÉLEVÉE (CVSS 8.4) touchant com.okta.sdk:okta-sdk-root, java management sdk (okta).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.21%, plus élevée que 10.8% des vulnérabilités.
- Correctif : mettre à jour vers 20.0.1 ou plus récent.
Description
Description
In the Okta Java SDK, race conditions may arise from concurrent requests using the ApiClient class. This could cause a status code or response header from one request’s response to influence another request’s response.
Affected product and versions
You may be affected if you meet the following preconditions:
- Using the Okta Java SDK between versions 11.0.0 and 20.0.0, and
- Implementing a multithreaded application with the ApiClient class where the response status code is used in access control flows
Resolution
Upgrade Okta/okta-sdk-java to versions 21.0.0 or greater.
NVD description
Okta Java Management SDK facilitates interactions with the Okta management API. In versions 11.0.0 through 20.0.0, race conditions may arise from concurrent requests using the ApiClient class. This could cause a status code or response header from one request’s response to influence another request’s response. This issue is fixed in version 20.0.1.
Autres vulnérabilités de com.okta.sdk:okta-sdk-root
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free