En bref
- CVE-2025-67721 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant io.airlift:aircompressor, io.airlift:aircompressor-v3, aircompressor (airlift).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.53%, plus élevée que 44.8% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.3, 3.4 ou plus récent.
Description
Summary
Incorrect handling of malformed data in Java-based decompressor implementations for Snappy and LZ4 allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data.
Details
With certain crafted compressed inputs, elements from the output buffer can end up in the uncompressed output. This is relevant for applications that reuse the same output buffer to uncompress multiple inputs. This can be the case of a web server that allocates a fix-sized buffer for performance purposes. This is similar to GHSA-cmp6-m4wj-q63q.
Impact
Applications using aircompressor as described above may leak sensitive information to external unauthorized attackers.
Mitigation
The vulnerability is fixed in release 3.4 and 2.0.3. However, it can be mitigated by either:
- Avoiding reuse of the decompression buffer across calls
- Clearing the decompression buffer before a call to decompress data
NVD description
Aircompressor is a library with ports of the Snappy, LZO, LZ4, and Zstandard compression algorithms to Java. In versions 3.3 and below, incorrect handling of malformed data in Java-based decompressor implementations for Snappy and LZ4 allow remote attackers to read previous buffer contents via crafted compressed input. With certain crafted compressed inputs, elements from the output buffer can end up in the uncompressed output, potentially leaking sensitive data. This is relevant for applications that reuse the same output buffer to uncompress multiple inputs. This can be the case of a web server that allocates a fix-sized buffer for performance purposes. There is similar vulnerability in GHSA-cmp6-m4wj-q63q. This issue is fixed in version 3.4.
Autres vulnérabilités de io.airlift:aircompressor
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free