En bref
- CVE-2025-68438 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant apache-airflow, airflow (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.62%, plus élevée que 49.5% des vulnérabilités.
- Correctif : mettre à jour vers 3.1.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.1.0, < 3.1.6
| 3.1.6
|
| airflow | ≥ 3.1.0, < 3.1.6
| 3.1.6
|
Description
In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display.
Users are recommended to upgrade to 3.1.6 or later, which fixes this issue
NVD description
In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display.
Users are recommended to upgrade to 3.1.6 or later, which fixes this issue
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free