En bref
- CVE-2025-68470 est une vulnérabilité MOYENNE (CVSS 6.5) touchant react-router (shopify), react-router.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.49%, plus élevée que 42.3% des vulnérabilités.
- Correctif : mettre à jour vers 6.30.2, 7.9.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| react-router | ≥ 6.0.0, ≤ 6.30.1≥ 7.0.0, ≤ 7.9.5
| No fix yet |
| react-router npm | ≥ 6.0.0, < 6.30.2≥ 7.0.0, < 7.9.6
| 6.30.27.9.6
|
Description
An attacker-supplied path can be crafted so that when a React Router application navigates to it via navigate(), <Link>, or redirect(), the app performs a navigation/redirect to an external URL. This is only an issue if developers pass untrusted content into navigation paths in their application code.
NVD description
React Router is a router for React. In versions 6.0.0 through 6.30.1 and 7.0.0 through 7.9.5, an attacker-supplied path can be crafted so that when a React Router application navigates to it via navigate(), <Link>, or redirect(), the app performs a navigation/redirect to an external URL. This is only an issue if you are passing untrusted content into navigation paths in your application code. This issue has been patched in versions 6.30.2 and 7.9.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free