En bref
- CVE-2026-105868 est une vulnérabilité ÉLEVÉE (CVSS 7.1) touchant payload (payloadcms), payload.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.17%, plus élevée que 5.8% des vulnérabilités.
- Correctif : mettre à jour vers 3.90.0, 4.0.0-canary.34 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| payload | = 4.0.0< 3.90.0
| 3.90.0
|
| payload npm | ≥ 4.0.0-canary.0, < 4.0.0-canary.34< 3.90.0
| 4.0.0-canary.343.90.0
|
Description
Impact
Under certain local upload configurations, an uploaded XML file and stylesheet could execute JavaScript in the Payload origin when a logged-in user opens the file.
You are affected if:
- You accept XML uploads (accepted by default).
Patches
Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Workarounds
Disallow XML/XSL uploads.
NVD description
Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, local upload configurations that accept XML files can store an XML file and stylesheet that execute JavaScript in the Payload origin when a logged-in user opens the file. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free