En bref
- CVE-2026-1115 est une vulnérabilité CRITIQUE (CVSS 9.6) touchant lollms, lollms (lollms).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 69.6% des vulnérabilités.
- Correctif : mettre à jour vers 2.2.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| lollms PyPI | < 2.2.0
| 2.2.0
|
| lollms | ≤ 2.1.0
| No fix yet |
Description
A Stored Cross-Site Scripting (XSS) vulnerability was identified in the social feature of parisneo/lollms, affecting the latest version prior to 2.2.0. The vulnerability exists in the create_post function within backend/routers/social/__init__.py, where user-provided content is directly assigned to the DBPost model without sanitization. This allows attackers to inject and store malicious JavaScript, which is executed in the browsers of users viewing the Home Feed, including administrators. This can lead to account takeover, session hijacking, and wormable attacks. The issue is resolved in version 2.2.0.
NVD description
A Stored Cross-Site Scripting (XSS) vulnerability was identified in the social feature of parisneo/lollms, affecting the latest version prior to 2.2.0. The vulnerability exists in the `create_post` function within `backend/routers/social/__init__.py`, where user-provided content is directly assigned to the `DBPost` model without sanitization. This allows attackers to inject and store malicious JavaScript, which is executed in the browsers of users viewing the Home Feed, including administrators. This can lead to account takeover, session hijacking, and wormable attacks. The issue is resolved in version 2.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free