En bref
- CVE-2026-113789 est une vulnérabilité MOYENNE (CVSS 6.0) touchant pypdf.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.39%, plus élevée que 33.3% des vulnérabilités.
- Correctif : mettre à jour vers 6.21.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.0
| 6.21.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage and/or long runtimes. This requires retrieving the form fields of a document.
Patches
This has been fixed in pypdf==6.21.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4219.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.0, an attacker can craft a PDF that causes large memory usage or long runtimes when an application retrieves the document's form fields. This issue is fixed in version 6.21.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free