En bref
- CVE-2026-113790 est une vulnérabilité MOYENNE (CVSS 6.0) touchant pypdf.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.39%, plus élevée que 33.3% des vulnérabilités.
- Correctif : mettre à jour vers 6.21.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.0
| 6.21.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing arrays and/or dictionaries with lots of elements.
Patches
This has been fixed in pypdf==6.21.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4218.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.0, an attacker can craft a PDF containing arrays or dictionaries with many elements, causing parsing to consume large amounts of memory. This issue is fixed in version 6.21.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free