En bref
- CVE-2026-115585 est une vulnérabilité ÉLEVÉE (CVSS 7.1) touchant pypdf.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.41%, plus élevée que 35.2% des vulnérabilités.
- Correctif : mettre à jour vers 6.21.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.2
| 6.21.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with repeated malformed cross-reference streams.
Patches
This has been fixed in pypdf==6.21.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4240.
Notes
This is a follow-up to https://github.com/py-pdf/pypdf/security/advisories/GHSA-55h5-xmcq-c37v, which had the side-effect of still loading the whole stream again despite the cache being present.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an incomplete remediation for repeated malformed cross-reference entries in GHSA-55h5-xmcq-c37v could still trigger a complete PDF stream reload during each recovery attempt even when a recovery cache was present, causing crafted cross-reference streams to produce long runtimes. This issue is fixed in version 6.21.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free